En effet, dès le départ, dès que le commercial m'en avait parlé, j'avais tout de suite émis un avis négatif.
Toutes les lectures que j'avais eu sur le sujet y était pour une partie, l'autre étant du fait que les logiciels que nous distribuions à nos collègues fonctionnaient en mode client/serveur, mais entrainaient énormément de trafic réseau et que l'Ethernet 10 Mbits/sec était vraiment le strict minimum pour avoir des temps de réponses acceptables, et très honorables à 100 MBits/sec ...

Malgré tout, le commercial n'a pas voulu tenir compte de ma remarque, ni proposer au client d'autres solutions que je lui avais préconisées et a donc passé commande pour le matériel cité ci-dessus ...

Il s'agissait d'un kit US Robotics, qui se présentait comme ça :



Un point d'accès et deux cartes PCI dans lesquelles s'enfichaient des cartes PCMCIA (ou PCCard, comme on dit maintenant ;-) ).

Mes premiers tests au bureau (bien à contre-coeur, je dois l'avouer :bof: , mais il faut bien bosser), se sont avérés catastrophiques ! En effet, l'installation était déjà d'une complexité phénoménale et si l'on ne suivait pas la procédure, on pouvait reformater la machine et recommencer :grr:
Une fois l'installation réussie, je suis passé aux tests de débits ... catastrophiques encore ... :grr:
En effet, même en tournant l'arrière du PC et en le positionnant à 50 cms du point d'accès, on atteignait même pas les 11 Mbits/sec prévus ! On plafonnait royalement à 5 ou 6 Mbits/sec, soit environ 20 fois le débit nécessaire au fonctionnement correct de nos applications ... Ca promettait !

Deuxième test : le point d'accès à un étage avec un des PC et le deuxième PC à l'étage du dessus ... Résultat : un débit royal de 2 Mbits/sec si personne ne passait dans le champ, et 1 Mbits/sec en cas de présence humaine ... :evil:
Bon, je dois avouer que le batiment dans lequel je procédais aux tests était neuf et était bati sur une architecture ou le métal était très présent, de même que les cloisons se trouvaient être du placoplâtre monté sur rails en aluminium ...

Je me suis dit, que chez le client, comme le bâtiment était classé, les murs devaient être en pierre et que la qualité du signal devait être meilleure ...

Une fois sur place, effectivement, les murs et le plafond étaient bien en pierres ... de plus 50 cm d'épaisseur, 80 cm par endroits ! La Mairie se trouvait dans un ... château !
Résultat : j'ai réussi à obtenir le débit phénoménal de 5 Mbits, en positionnant le point d'accès au plus proche et en orientant les machines vers celui-ci. les machines étant bien sur posées sur les bureaux (alors qu'il s'agissait de tours ...), car si on les plaçaient sous les bureaux, le débit tombait à 1 Mbits/sec ...

En conclusion : nous étions obligés de nous déplacer chez ce client environ une fois par trimestre pour remplacer les cartes PCMCIA qui lâchaient à tour de rôle au gré des orages et/ou surtensions électriques dûes à l'installation datant de plus de 20 ans. Le nombre de cartes utilisées est phénoménale et loin, très loin d'être rentable ....
Pour finir, vous imaginez le mécontentement important du client qui se retrouvait avec un réseau fonctionnant au rythme des signaux de fumées des sioux s'envoyant des messages entre eux :rigole:
Et bien entendu, devinez sur qui est retombé tout cela ... Sur moi, bien sur ! J'étais Responsable Technique, mais surtout responsable des dysfonctionnements et lorsque tout marchait bien, c'était soi-disant grâce au commercial qui avait bien fait son boulot !
A ma charge de trouver une solution pour que ce réseau fonctionne à 11 Mbits/sec au moins, comme indiqué sur la boite ...
Vous vous imaginez bien que je ne pouvais pas résoudre ce problème :P

Deux ans se sont écoulés comme cela, sans que je ne puisse rien faire pour améliorer ce réseau sans en en changer ces modules Wifi ...
Avant mon départ de la société vers un nouveau job et de nouveaux horizons, j'avais proposé d'utiliser les câbles du réseau téléphonique de la Mairie (qui bizarrement, eux avaient le droit de traverser les murs ... :hein: ) et d'installer deux routeurs SDSL Zyxel sur ces paires de cuivre ...
Le prix des deux routeurs couvrant l'achat de 4 cartes PCMCIA telles que celles installées chez le client.



En effet, j'avais, pour un autre client présentant une problématique de distance, validé cette solution. Elle permettait d'offrir facilement des débits de 18 Mbits/sec sur une distance de 1,2 kms (débit assuré par le constructeur et mesuré par mes soins...)
Même avec un débit 5 fois inférieur à celui recommandé, le réseau devenait tout de même utilisable, car il arrivait au niveau d'un réseau 10 Mbits/sec, type de réseau sur lequel nous avions tout de même travaillé durant quelques années.

A ce jour et à ma connaissance, mon ancien client est toujours dans son chateau, avec son réseau Wifi hyper-rapide à 1 ou 2 Mbits/sec, et ses changements de cartes réguliers .... ;-)
Pourquoi ? Parce que cela ne coute rien au client, car presque chaque achat de l'époque était couvert par un contrat de maintenance. Et, dans le cadre de ce contrat, le client était en droit de demander à ce qu'on lui remette son réseau état, tel qu'il l'avait acheté ...
Les contrats durants généralement 5 ans, il doit bientôt arriver à terme et j'espère cette fois-ci que mon avis sur la solution SDSL préconisée il y a un peu plus de deux ans ou sur un réseau Wifi plus performant sera retenu et que ce client pourra enfin obtenir un réseau à la hauteur de ses espérances ...

Thierry.

P.S. : Ce billet est un prélude à un autre billet à venir vous présentant mon passage à du vrai Wifi depuis environ 1 semaine sur mon réseau personnel ... :-)

P.S. 2 : Je n'ai rien contre les commerciaux, en particulier mon ancien collègue (qui était aussi un ami ...), car je sais que parfois il faut savoir dire oui au client pour lui démontrer qu'il à tort ... Et je reste persuadé que c'est pour cela que mon collègue avait accepté de vendre cette solution ...